no connection to postgres 8.3.7 PT2

Forum with tips, support, etc, on using the PostgreSQL database with Poker Tracker. Please post any PostgreSQL questions here.

no connection to postgres 8.3.7 PT2

Postby ines27 » Sat May 02, 2009 6:06 am

my pt2 does not connect to postgres.

the PT2 error message says:

"101SQLsate=08001, connection refused. Is the server running on host "localhost" and accepting TCP/IP on port 5432?"



some weeks ago I changed my computer, reinstalled windows 2000 professional, replaced some components and bla. I reinstalled postgres, using the uninstall tool first and installed the newer 8.3.7.

I already installed the odbc driver manually, using "application stack builder". but I dont know where I can see how and where I have to change settings, so that the host is 127xxx and accepting TCP/IP, based on that -similar- question:


"Is the server running on host "127.xxx" and accepting TCP/IP connections on 5432?"

I also installed pg admin 1.8 III, but also dont know what I should change or set there. the "connect" window there is "deactivated", means I cant set a checkmark there, so obviously something is missing.
the start/restart server does not work as well-it does not start;)

I would also reinstall pt2 or postgres if it helps because I dont have any big databases, only a little access db that I cant change to postgres. my pt2 registration email is another one than this, if needed I will email it to you.

ty for any support.
ines27
 
Posts: 3
Joined: Sun Oct 05, 2008 8:57 am

Re: no connection to postgres 8.3.7 PT2

Postby ptrack pat » Sat May 02, 2009 7:34 am

go to the c:\program files\postgresql\8.3\data folder. Is there a file called postmaster.pid there? If so, delete it.

Then go to the Start > Settings > Control Panel > Administrative Tools > Services window.
Find PostgreSQL 8.3 Database Service in the list. Right-click on it and select "Start". Does this work or give an error? If it works, try PT again. If it gives an error, what is it?
ptrack pat
 
Posts: 4841
Joined: Sun Dec 09, 2007 12:38 pm

Re: no connection to postgres 8.3.7 PT2

Postby ines27 » Sun May 03, 2009 6:08 am

there is no postmaster pid in data. its empty.

I did not find a postgresdatabase service.

what I found is a window after using start/start> einstellungen/settings >systemsteuerung/control panel>verwaltung/administrative tools>dienste/services>postgresql server. so there is the server but no "service". with the old postgres 8.0 I always started "service" if there where connection problems what worked very well.


I can try to connect there, it does not work and says:...(my bad translation): "trying to connect to local computer>the service "postgresql 8.3 server" could not be started on "local computer".The service replied no error. It could be an internal windows error or an internal service error. ask systemadministrator if problem stays..."
ines27
 
Posts: 3
Joined: Sun Oct 05, 2008 8:57 am

Re: no connection to postgres 8.3.7 PT2

Postby ptrack pat » Sun May 03, 2009 10:32 am

Until you can start the service, PT won't work. I don't know what would be preventing it from starting. Try uninstalling and reinstalling PostgreSQL.
ptrack pat
 
Posts: 4841
Joined: Sun Dec 09, 2007 12:38 pm

Re: no connection to postgres 8.3.7 PT2

Postby ines27 » Sun May 03, 2009 12:47 pm

I changed to postgres 8.2, now everything works...
ines27
 
Posts: 3
Joined: Sun Oct 05, 2008 8:57 am


Return to PostgreSQL Forum

Who is online

Users browsing this forum: No registered users and 0 guests